بهترین نسخه php وردپرس | کدام نسخه سریع‌تر است

انجمن‌های خارجی چند سالی است که در مورد نسخه پی اچ پی مناسب وردپرس بحث و گفت و گو دارند. جالب اینکه امروز ما نسخه‌های بسیار جدید یعنی php 8.1 را داریم. اما کدام نسخه بهترین عملکرد را دارد؟

در تستی که ما روی سایت راه دیجیتال انجام دادیم در صورت نصب بودن وردپرس خام به همراه قالب‌های پیش‌فرض وردپرس بهترین عملکرد را روی php 8 داشت، اما مشکل از جایی شروع می‌شود که تصمیم می‌گیرید از پلاگین ها و قالب‌های موجود در وب استفاده کنید. اکثر افزودنی‌های وردپرس مشکلاتی با نسخه‌های جدید پی اچ پی دارند.

وردپرس چه می گوید؟

وردپرس در وب سایت رسمی خود پیشنهاد داده که برای اجرای وردپرس از یک‌هاست که از نسخه php 7.4 و بالاتر پشتیبانی می‌کند استفاده کنید. وردپرس همچنین عنوان کرده که اجباری نیست و تقریبا وردپرس حتی با نسخه‌های قدیمی مانند ۷ و ۵.۶ هم سازگار است.. اما پیشنهاد می دهد به جهت مسائل امنیتی حتماً از آخرین نسخه php استفاده کنید.

همچنین در بخش سلامت وردپرس اگر نسخه php شما کمتر از 7.3 باشد به شما اعلام کند که وضعیت سلامت سایت شما خوب نیست.

وردپرس در کنار پی اچ پی پیشنهاد می‌دهد که از هاستینگی استفاده کنید که mysql 5.6 و بالاتر یا mariadb 10 و بالاتر روی آن نصب شده باشد.

پی اچ پی های قبل تر از ۷.۴ دیگر پشتیبانی نمی‌شوند

سال ۲۰۱۸ آخرین سالی بود که php 5.6 و php 7 پشتیبانی می‌شدند و عملاً در صورت وجود باگ‌ها امنیتی و مشکلات ساختاری در این نسخه‌ها هیچ به روز رسانی در کار نخواهد بود. هر زمان که یک نسخه از پی اچ پی پشتیبانی نشود باید فورا نسبت بع تغییر آن اقدام کنید.

php 5.6: پایان پشتیبانی در دسامبر ۲۰۱۸

php 7: پایان پشتیبانی ژانویه ۲۰۱۹

php 7.1: پایان پشتیبانی دسامبر ۲۰۱۹

php 7.2: پایان پشتیبانی نوامبر ۲۰۲۰

php 7.3: پایان پشتیبانی دسامبر ۲۰۲۱

معمولا هر نسخه از پی‌اچ‌پی تا ۳ سال آپدیت رفع باگ دریافت می‌کند.

کدام نسخه از php مناسب است

تمامی نسخه‌های بالا تا ۷.۳ همان‌طور که دیدید از پشتیبانی خارج شده‌اند. پس تنها گزینه ما php 7.4 و بالاتر است. طبق تستی که ما در راه‌دیجیتال انجام داده‌ایم وردپرس هنوز عملکرد خوبی با php 8.1 ندارد اما php 8 در صورت پشتیبانی سایر افزونه‌ها و قالب‌های شما بهترین گزینه است.

نسخه ۷.۴ پی اچ پی همچنان سازگارترین نسخه

بسیاری از افزونه ها و قالب های وردپرس با نسخه های جدید php سازگاری مناسبی ندارند. به همین خاطر در بیشتر مواقع اگر نسخه php هاست خود را روی ۸ یا ۸.۱ قرار دادید و سایت شما با ارور مواجه شد میتوانید به نسخه ۷.۴ برگردانید.

در مجموع می‌توان این‌طور نتیجه گیری کرد که بهتر است افزونه ها و قالب سایتتان را به نسخه های جدید به روز رسانی کنید و بعد php را به 7.4 ارتقا دهید.

فراموش نکنید که یک هاست وردپرس واقعی امکان ارتقا به php ۸ را داراست. حدود ۱ سال از انتشار نسخه ۸ پی‌اچ‌پی میگذرد و اکثر محصولات پرنصب با این نسخه سازگار‌اند، اما محصولات ایرانی و مارکت‌های ایرانی به خاطر کدگذاری معمولا در بهترین حالت با php 7.4 سازگار هستند.

نسخه ۸ چقدر بهتر است؟

اول باید بدانیم که آپدیت‌ها برای رفع مشکلات ساختاری یا امنیتی منتشر می‌شوند. با این ایده پس احتمالا همیشه باید بکوشید که از آخرین نسخه استفاده کنید. به خصوص اینکه پشتیبانی از نسخه ۷.۴ نیز به زودی تمام می‌شود.

نسخه ۸ به نسبت نسخه ۷.۴ از نظر عملکرد وردپرس حدود ۱۵ درصد سریع‌تر و بهتر عمل می‌کند.

نظرت‌رو بگو
8 دیدگاه
  1. آواتار علی
    علی می‌گوید

    سلام من وقتی php 7.3 تنظیم میکنم سایتم دیگه بالا نمیاد

    1. آواتار سروش احمدی
      سروش احمدی می‌گوید

      سلام خدمت شما
      احتمالا تعدادی از افزونه ها و قالب های شما قدیمی هست.
      بهتره قبل از هر چیز همه موارد رو به روز رسانی کنید.

  2. آواتار masumi
    masumi می‌گوید

    سلام دوستان خسته نباشید.
    من یک سایت با وردپرس در لوکال طراحی کردم حالا میخام در شبکه یک سرکت برای کاربران به اشتراک بزارم. نکته اینجاست که این شرکت هیچگونه دسترسی به اینترنت ندارد.فقط اینترانت هسش(شبکه داخلی).چطوری میشه این چالش رو برطرف کرد؟؟؟؟؟

    1. آواتار پشتیبان راه دیجیتال
      پشتیبان راه دیجیتال می‌گوید

      درود ❤️ – باید با مفاهیم شبکه کردن آشنا باشید. اما احتمالا بعد از شبکه کردن با وارد کردن آی پی 127.0.0.1 امکان دسترسی وجود داشته باشد.

  3. آواتار حسین میرزائی
    حسین میرزائی می‌گوید

    سلام خسته نباشید من php رو روی 7.4 قرار دادم ولی وقتی صفحه اصلی سایت رو باز میکردم نوشته بود هاست شما از MySQL پشتیبانی نمیکنه این مشکل میدونید از چی هست

    1. آواتار پشتیبان راه دیجیتال
      پشتیبان راه دیجیتال می‌گوید

      درود ❤️ – به کمک روش عیب یابی ابتدا با وردپرس را آپدیت کنید و سپس افزونه ها را غیر فعال و یکی یکی فعال کنید تا افزونه یا قالبی که ممکن است این مشکل را ایجاد کرده پیدا کنید.

  4. آواتار حسین میرزائی
    حسین میرزائی می‌گوید

    پی اچ پی 7.4 درست شد روی پی اچ پی 8 هم میبزارم بازم مینویسه هاست شما از MySQL پشتیبانی نمیکن برای این هم باید وردپرس رو اپدیت کنم و بعد افزونه ها رو غیر فعال کنم

    1. آواتار پشتیبان راه دیجیتال
      پشتیبان راه دیجیتال می‌گوید

      درود ❤️ – php 8 هنوز نسخه پایدار نداره. از نسخه 7.4 استفاده کنید.